Back to overview
Resolved

Adding DDos Protection & Optimizing Website

Apr 24, 2026 at 5:47pm UTC  –  Apr 25, 2026 at 7:57am UTC
Affected services
ZCraft Main Site
Z-craft.xyz/play
Z-craft.xyz/login
z-craft.xyz/register

Resolved
Apr 25, 2026 at 7:57am UTC

Maintenance ended

Created
Apr 24, 2026 at 5:47pm UTC

Website has been fixed and updated with new protection and improvements